IP

List Port Game Online di Mikrotik


/ip firewall mangle
add action=mark-connection chain=prerouting comment=Point Blank dst-port=9100,9200,39190 new-connection-mark=game-online protocol=tcp
add action=mark-connection chain=prerouting dst-port=40000-40010 new-connection-mark=game-online protocol=udp

add action=mark-connection chain=prerouting comment=Dragon Nest dst-port=14300-14440,14400-14501 new-connection-mark=game-online protocol=tcp
add action=mark-connection chain=prerouting dst-port=15100-15150 new-connection-mark=game-online protocol=udp

add action=mark-connection chain=prerouting comment=DOTA2 dst-port=27014-27050 new-connection-mark=game-online protocol=tcp
add action=mark-connection chain=prerouting dst-port=4380,3478,4379,27000-27050 new-connection-mark=game-online protocol=udp

add action=mark-connection chain=prerouting comment=FIFA-Online dst-port=7770-7790 new-connection-mark=game-online protocol=tcp
add action=mark-connection chain=prerouting dst-port=16320-16340 new-connection-mark=game-online protocol=udp

add action=mark-connection chain=prerouting comment=AyoDance dst-port=18900-18910 new-connection-mark=game-online protocol=tcp

add action=mark-connection chain=prerouting comment=Cross Fire dst-port=10009,13008,16666,28012 new-connection-mark=game-online protocol=tcp
add action=mark-connection chain=prerouting dst-port=12020-12080,13000-13080 new-connection-mark=game-online protocol=udp

add action=mark-connection chain=prerouting comment=Lost Saga dst-port=14000-14050 new-connection-mark=game-online protocol=tcp
add action=mark-connection chain=prerouting dst-port=14000-14050 new-connection-mark=game-online protocol=udp

add action=mark-connection chain=prerouting comment=CSO dst-port=36567,47611,8002-8010 new-connection-mark=game-online protocol=tcp
add action=mark-connection chain=prerouting dst-port=27005-27015 new-connection-mark=game-online protocol=udp

add action=mark-packet chain=prerouting connection-mark=game-online new-packet-mark=Packet-Game passthrough=yes

Template Voucher Userman

HEADER
<!DOCTYPE html> <html> <title>XXX Hotspot</title> <meta charset="UTF-8"> <meta name="viewport" content="width=device-width, initial-scale=1"> <link rel="stylesheet" href="https://www.w3schools.com/lib/w3.css"> <link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Raleway"> <script src="http://www.sys2u.com/qrcode/jquery.min.js" type="text/javascript"></script> <script src="http://www.sys2u.com/qrcode/jquery.qrcode.min.js" type="text/javascript"></script> <style> body,h1,h2,h3,h4,h5,h6 {font-family: "Raleway", sans-serif} @page {size: A4; margin: 0;} @media print {html, body {width: 210mm; height: 297mm; margin-left: auto; margin-right: auto;}} @media screen {html, body {width: 400px;}} body{padding: 5mm; margin:0; margin-left: auto; margin-right: auto;} #main-wrap {background-color: #fff; border: solid; border-width: 1px; display: inline-block;} #main-wrap {overflow: hidden; width: 45%;} #leftside {display: inline-block; width: 50%;} #rightside {display: inline-block; width: 45%;} </style> <body>

ROW
<div id="main-wrap"> <header class="w3-container w3-black"><h6>XXX HotSpot</h6></header> <div class="w3-white">Profile : <b>%u_actualProfileName%</b><br>Username : <b>%u_username%</b><br>Password : <b>%u_password%</b></div> <div class="w3-container w3-white"><center><div class="qrcode" id="%u_username%"></div></center> <script> jQuery(function(){jQuery('#%u_username%').qrcode({"render": 'div', "size": 100, "minVersion": 5, "maxVersion": 5, "ecLevel": 'L', "mode": 0, "text": "http://10.5.50.1/login?username=%u_username%&password=%u_password%", "quiet": 0,});})</script></div> <footer class="w3-container w3-black"><font size="2px"> Cp : 08123456789</font></footer> </div>

FOOTER
</div> <!-- end of <div class="w3-row-padding"> --> </body></html>

BREAK
<p class="noprint" style="font-size: 10px"> ................ page break ................ </p> <p class="pagebreak">&nbsp;</p>

 Sumber : goo.gl/qVGjcZ

Setup Mariadb Galera Cluster 10 Centos 6


vi /etc/yum.repos.d/mariadb.repo
[mariadb]
name = MariaDB
baseurl = http://yum.mariadb.org/10.0/centos6-amd64
gpgkey=https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
gpgcheck=1

setenforce 0

vi /etc/selinux/config 
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#     targeted - Targeted processes are protected,
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

yum install http://dl.fedoraproject.org/pub/epel/6/x86_64/socat-1.7.2.3-1.el6.x86_64.rpm

yum install MariaDB-Galera-server MariaDB-client rsync galera

/etc/init.d/mysql start

/usr/bin/mysql_secure_installation

vi /etc/my.cnf.d/server.cnf 
[mariadb-10.0]

query_cache_size=0
binlog_format=ROW
default_storage_engine=innodb
innodb_autoinc_lock_mode=2
wsrep_provider=/usr/lib64/galera/libgalera_smm.so
wsrep_cluster_address="gcomm://192.168.250.137"
wsrep_cluster_name='cluster1'
wsrep_node_address='192.168.250.137'
wsrep_node_name='db1'
wsrep_sst_method=rsync
wsrep_sst_auth=root:dbpass

vi /etc/rc.local
#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local
/etc/init.d/mysql start --wsrep-new-cluster
iptables -I INPUT 5 -p tcp -m state --state NEW -m tcp --dport 3306 -j ACCEPT
iptables -I INPUT 5 -p tcp -m state --state NEW -m tcp --dport 4444 -j ACCEPT
iptables -I INPUT 5 -p tcp -m state --state NEW -m tcp --dport 4567 -j ACCEPT
iptables -I INPUT 5 -p tcp -m state --state NEW -m tcp --dport 4568 -j ACCEPT

Create MariaDB Galera Users
mysql -u root -p
MariaDB [(none)]> delete from mysql.user where user ='';
MariaDB [(none)]> grant all on *.* to 'root'@'%' identified by 'dbpass';
MariaDB [(none)]> grant usage on *.* to root@'%' identified by 'dbpass';
MariaDB [(none)]> grant all privileges on *.* to root@'%';
MariaDB [(none)]> flush privileges;

mysql -uroot -p -e "show status like 'wsrep%'"
+------------------------------+--------------------------------------+
| Variable_name                | Value                                |
+------------------------------+--------------------------------------+
| wsrep_local_state_uuid       | bd2acb32-30a6-11e7-863d-32dc104a6a9e |
| wsrep_protocol_version       | 7                                    |
| wsrep_last_committed         | 0                                    |
| wsrep_replicated             | 0                                    |
| wsrep_replicated_bytes       | 0                                    |
| wsrep_repl_keys              | 0                                    |
| wsrep_repl_keys_bytes        | 0                                    |
| wsrep_repl_data_bytes        | 0                                    |
| wsrep_repl_other_bytes       | 0                                    |
| wsrep_received               | 2                                    |
| wsrep_received_bytes         | 142                                  |
| wsrep_local_commits          | 0                                    |
| wsrep_local_cert_failures    | 0                                    |
| wsrep_local_replays          | 0                                    |
| wsrep_local_send_queue       | 0                                    |
| wsrep_local_send_queue_max   | 1                                    |
| wsrep_local_send_queue_min   | 0                                    |
| wsrep_local_send_queue_avg   | 0.000000                             |
| wsrep_local_recv_queue       | 0                                    |
| wsrep_local_recv_queue_max   | 2                                    |
| wsrep_local_recv_queue_min   | 0                                    |
| wsrep_local_recv_queue_avg   | 0.500000                             |
| wsrep_local_cached_downto    | 18446744073709551615                 |
| wsrep_flow_control_paused_ns | 0                                    |
| wsrep_flow_control_paused    | 0.000000                             |
| wsrep_flow_control_sent      | 0                                    |
| wsrep_flow_control_recv      | 0                                    |
| wsrep_cert_deps_distance     | 0.000000                             |
| wsrep_apply_oooe             | 0.000000                             |
| wsrep_apply_oool             | 0.000000                             |
| wsrep_apply_window           | 0.000000                             |
| wsrep_commit_oooe            | 0.000000                             |
| wsrep_commit_oool            | 0.000000                             |
| wsrep_commit_window          | 0.000000                             |
| wsrep_local_state            | 4                                    |
| wsrep_local_state_comment    | Synced                               |
| wsrep_cert_index_size        | 0                                    |
| wsrep_causal_reads           | 0                                    |
| wsrep_cert_interval          | 0.000000                             |
| wsrep_incoming_addresses     | 192.168.250.137:3306                 |
| wsrep_desync_count           | 0                                    |
| wsrep_evs_delayed            |                                      |
| wsrep_evs_evict_list         |                                      |
| wsrep_evs_repl_latency       | 0/0/0/0/0                            |
| wsrep_evs_state              | OPERATIONAL                          |
| wsrep_gcomm_uuid             | bd2a3ca4-30a6-11e7-bbf5-d31cbeec95a8 |
| wsrep_cluster_conf_id        | 1                                    |
| wsrep_cluster_size           | 1                                    |
| wsrep_cluster_state_uuid     | bd2acb32-30a6-11e7-863d-32dc104a6a9e |
| wsrep_cluster_status         | Primary                              |
| wsrep_connected              | ON                                   |
| wsrep_local_bf_aborts        | 0                                    |
| wsrep_local_index            | 0                                    |
| wsrep_provider_name          | Galera                               |
| wsrep_provider_vendor        | Codership Oy    |
| wsrep_provider_version       | 25.3.19(r3667)                       |
| wsrep_ready                  | ON                                   |
| wsrep_thread_count           | 2                                    |
+------------------------------+--------------------------------------+



Install Mysql 5.5 Di Centos 6.8


yum -y install mysql mysql-server
rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
yum -y install mysql.`uname -i` yum-plugin-replace
yum replace mysql --replace-with mysql55w


NTP Server Centos 6.8


Network Time Protocol (NTP) yaitu protokol untuk mensinkronisasikan jam pada sistem komputer, variabel-latency jaringan data. NTP menggunakan protokol UDP pada port 123 sebagai lapisan transport.
Berikut cara untuk membuat NTP Server pada CentOs 6.8

1. Install and Configure NTPd
[root@ntp ~]# yum -y install ntp
[root@ntp ~]# vi /etc/ntp.conf
# pada baris 19: menambahkan jangkauan jaringan yang akan mengakses NTP Server
restrict 192.168.0.0 mask 255.255.255.0 nomodify notrap
# mengubah server untuk sinkronisasi ke zona waktu Anda
#server 0.centos.pool.ntp.org iburst
#server 1.centos.pool.ntp.org iburst
#server 2.centos.pool.ntp.org iburst
#server 3.centos.pool.ntp.org iburst
server id.pool.ntp.org
server 0.id.pool.ntp.org

[root@ntp ~]# /etc/rc.d/init.d/ntpd start 
Starting ntpd: [ OK ]
[root@ntp ~]# chkconfig ntpd on

2. Jika Iptables berjalan, maka berikan akses untuk port NTP. NTP menggunakan 123 / UDP.
[root@ntp ~]# iptables -I INPUT 5 -p udp -m state --state NEW -m udp --dport 123 -j ACCEPT

3. Lakukan pengecekan apakah NTP sudah berjalan normal
[root@ntp ~]# ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
+203.114.225.252 118.103.146.184  2 u  294 1024  373   16.309   13.068   7.263
+ntp0.laxo.net.i 202.65.114.202   3 u  162 1024  275    5.685   -2.172   1.723
 ns1.p-link.co.i .INIT.          16 u    - 1024    0    0.000    0.000   0.000
*ntp.lipi.go.id  203.160.128.66   2 u  250 1024  377    7.381   -4.033   5.451

Setting Cisco Catalyst 3560



hostname sw-cileungsi
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 4
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 5
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 6
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 7
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 8
 switchport mode access

Installasi Web Server HTTPS di Centos 6.8

Installasi Web Server HTTPS di Centos 6.8



1. Install httpd
yum -y install httpd

2. Edit file httpd
vi /etc/httpd/conf/httpd.conf

#pada line 44 : rubah menjadi Prod
ServerTokens Prod

#pada line 76 : rubah menjadi On
KeepAlive On

#pada line 262 : rubah email milik sendiri
ServerAdmin root@domainku.com

#pada line 276 : rubah server name nya
ServerName www.domainku.com:80

#pada line 338 : rubah menjadi All agar .htaccess dapat berjalan
AllowOverride All

#pada line 402 : tambahkan file extension agar dapat di akses pada folder var/www/html
DirectoryIndex Index.html index.htm index.php

#pada line 536 : rubah menjadi Off
ServerSignature Off

#pada line 759 : berikan tanda # didepan
#AddDefaultCharset UTF-8

3. Tambahkan rule berikut di iptables
vi /etc/sysconfig/iptables
-A INPUT -p tcp -m tcp --dport 80 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 443 -j ACCEPT

4. Restart Services HTTPD & IPTABLES
chkconfig httpd on
/etc/init.d/httpd restart
/etc/init.d/iptables restart

5. Test akses web server dengan cara http://ipaddresswebserver/ atau http://domainku.com/

Berikutnya Konfigurasi HTTPD dengan SSL connenction

6. Buat Certificate SSL
cd /etc/pki/tls/certs
make server.key
Enter pass phrase: #isikan password
Verifying – Enter pass phrase: #masukan kembali password

7. Lanjut masih di dalam folder certs
openssl rsa -in server.key -out server.key
Enter pass phrase for server.key: #masukan password yg sama dari step ke 6

8. Membuat Certificate Signing Request
make server.csr
umask 77 ; \
/usr/bin/openssl req -utf8 -new -key server.key -out server.csr

You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Country Name (2 letter code) [XX]:ID #masukan negara
State or Province Name (full name) [e]:Jakarta #provinsi
Locality Name (eg, city) [Default City]:Jakarta #kota
Organization Name (eg, company) [Default Company Ltd]:PT. XXX #perusahaan
Organizational Unit Name (eg, section) []:XXX #department
Common Name (eg, your server's hostname) []:www.domainku.com #masukan domain FQDN
Email Address []:xxx@domainku.com # email address

Please enter the following 'extra' attributes
to be sent with your certificate request
A challenge password []: # Enter
An optional company name []: # Enter

9. membuat signature dan expire certificate
openssl x509 -in server.csr -out server.crt -req -signkey server.key -days 3650
Signature ok
subject=/C=ID/ST=Jakarta/L=Jakarta/O=PT.XXX/OU=XXX/CN=www.domainku.com/emailAddress=xxx@domainku.com Getting Private key
chmod 400 server.*

10. Konfigurasi SSL di httpd
yum -y install mod_ssl

11. Edit file SSL.CONF
vi /etc/httpd/conf.d/ssl.conf
#pada line 77 : hilangkan tanda #
DocumentRoot “/var/www/html”

#pada line 78 : hilangkan tanda # dan rubah servername nya
ServerName www.domainku.com:443

#pada line 93 : rubah menjadi
SSLProtocol -All +TLSv1 +TLSv1.1 +TLSv1.2

#pada line 105
SSLCertificateFile /etc/pki/tls/certs/server.crt

#pada line 112
SSLCertificateKeyFile /etc/pki/tls/certs/server.key

12. Restart Services HTTPD
/etc/init.d/httpd restart

13. Akses Web Server dengan url https://ipwebserver.com/ atau https://domainku.com/

Setting DNS Server / Bind CentOS 6


Setting DNS Server / Bind CentOS 6



Ok kita langsung saja ke configurasi dan instalasi dns server pada centos 6.

1. Install package bind
yum install bind bind-utils

2. Kemudian edit konfigurasi named.conf yang terletak pada directory /etc dengan membuatkan zone forward dan zone reverse dengan mengetikkan perintah :
vi /etc/named.conf

kemudian isikan configurasi seperti berikut :

options {
listen-on port 53 { 127.0.0.1; 192.168.11.234; };
listen-on-v6 port 53 { ::1; };
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";

allow-query { 127.0.0.1; 192.168.11.234; any; };
allow-query-cache { 127.0.0.1; 192.168.11.234; any ;};
};

logging {
channel default_debug {
file "data/named.run";
severity dynamic;
};
};

zone "domain-anda.com" {
type master;
file "domain-anda.com.zone";
};

zone "11.168.192.in-addr.arpa" IN {
type master;
file "11.168.192.rev";
allow-update { none; };
};

3. Membuat zone forward terhadap domain domain-anda.com dengan nama file domain-anda.com.zone dan letakkan file tersebut di /var/named/. Isi dari konfigurasi file tersebut adalah :
$TTL 86400
@ IN SOA domain-anda.com. root.domain-anda.com.(
2008111914 ;Serial
3600 ;Refresh
1800 ;Retry
604800 ;Expire
86400 ;Minimum TTL
)

@ IN NS ns1.domain-anda.com.
@ IN NS ns2.domain-anda.com.
@ IN A 192.168.11.234
ns1 IN A 192.168.11.234
ns2 IN A 192.168.11.234
@ IN MX 10 mail.domain-anda.com.
www IN A 192.168.11.234
mail IN A 192.168.10.9

4. Setelah itu membuat zone reverse domain dengan tujuan mentranslasikan ip address dari server ke alamat domain yang merupakan kebalikan dari zone forward. Untuk zone reverse nama file dan lokasi file harus disesuaikan dengan nama dan lokasi yang telah ditentukan pada konfigurasi named.conf. Pada konfigurasi di atas nama reverse zone adalah 11.168.192.rev (IP Address server yang dibalik) dan diletakan dalam directory /var/named/ . Isikan konfigurasi reverse zone seperti berikut :
$TTL 86400
@ IN SOA domain-anda.com. root.domain-anda.com. (
2008111914 ;Serial
3600 ;Refresh
1800 ;Retry
604800 ;Expire
86400 ;Minimum TTL
)

IN NS ns1.domain-anda.com.
IN NS ns2.domain-anda.com.
234 IN PTR domain-anda.com.

5. Selanjutnya restart service bind dengan mengetikkan perintah :
/etc/init.d/named restart
atau
service named restart

Keterangan

SOA (Start Of Authority) untuk mengidentifikasikan otoritas name-server pada zone data atau informasi nama host domain.
TTL (Time To Live) merupakan waktu yang diperlukan server DNS untuk menyimpan hasil resolving ke cache-nya.
Serial merupakan nomor seri database-cache domain my-server.com. Jika ada perubahan data pada berkas zone domain-anda.com, misalnya menambahkan domain blog.domain-anda.com, maka anda harus merubah/menambah nomor serinya. Sebaiknya digunakan format tahun-bulan-tanggal-jam untuk nomor serialnya. Pada berkas database untuk zone domain domain-anda.com tersebut terakhir di-update tanggal 12 Mei 2016 jam 13. Fungsi dari serial ini adalah untuk memberitahukan kepada secondary-master name-server untuk meng-update database-cache-nya jika ada perubahan pada primary-master name-server yaitu dengan melakukan pengecekan nomor serial. Jika nomor serial berubah/bertambah maka secondary-master name-server akan segera melakukan zone-transfer dari primary-master name-server.
Refresh adalah selang waktu yang diperlukan (dalam detik) secondary-master name-server untuk melakukan pengecekan perubahan database-cache pada primary-master name-server.
Retry adalah waktu (dalam detik) yang digunakan secondary-master name-server untuk menunggu pengulangan cek berkas zone jika pada saat proses refresh primary-master name-server tidak memberikan respon
Expire adalah waktu (dalam detik) yang digunakan secondary-master name-server untuk mempertahankan berkas zone jika tidak dapat melakukan zone-refresh. Jika setelah waktu expire telah habis tapi secondary-master name-server tidak dapat melakukan zone-refresh maka berkas zone pada secondary-master name-server akan dihapus.
Minimum adalah nilai waktu (TTL) default untuk semua resource-record yang ada dalam berkas zone.
@ menunjukkan bahwa zone yang bersangkutan adalah zone domain yang ditunjukkan berkas named.conf ke berkas database-cache tersebut atau origin zone
IN adalah singkatan dari Internet. Semua informasi Internet digunakan IN dan untuk informasi non-Internet digunakan kode lain.
A menyatakan Address Internet atau alamat IP dari mesin yang ditangani oleh DNS ini proses penerjemahan namanya.
NS menyatakan Name Server.


NS Record merupakan daftar name-server yang otoritatif untuk zone bersangkutan. Pada database domain domain-anda.com name-servernya adalah ns1.domain-anda.com dan ns2.domain-anda.com. NS Record ini yang nantinya akan diserahkan kepada pengelola domain TLD (Top Leve Domain) agar terdaftar dalam registar domain.
MX (Mail Exchanger) merupakan record routing email, untuk domain domain-anda.com dalam hal ini akan diarahkan ke mail.domain-anda.com. sebagai host yang ditunjuk sebagai mail exchanger akan memproses atau meneruskan mail untuk domain domain-anda.com.
Angka 10 pada MX 10 mail.domain-anda.com. merupakan nilai preferensi (preference value) untuk menunjukkan tingkat prioritas mail exchanger yang digunakan untuk memproses atau meneruskan mail yang menuju domain my-server.com.